I cant run my next.js project

Problem description:
I can’t run my project. I have been building a site in next.js with no issues. I logged off earlier today after making some progress (and everything functioning correctly), when I returned about an hour later nothing works. When I hit run everything compiles correctly and the console says “ready” but the webview never loads. I even downloaded the reply as a zip file and ran the exact same project on my local machine with no issues.

Expected behavior:
When I hit run, I can test using the dev instance.

Actual behavior:
Everything appears to compile correctly but I’m unable to connect to my repl.

Steps to reproduce:
click run

Browser: Opera GX (happens on desktop app too)
OS: OS X Sonoma
Device (Android, iOS, NA leave blank): Macbook Air 15-inch, M2, 2023
Desktop app version (Avatar menu->“Version”) or NA: 1.0.6
Plan (Free, Replit Core): Core

If theres any information I can provide that would help, please let me know. The problem is there are no errors I can see - everything appears to work correctly.

More info: I can’t use run on ANY repl. I started a fresh Next.js and hit run, same issue. I started a fresh react, same issue.

Hi @evanluchs welcome to the forums!
Try running kill 1 in the Shell to refresh the environment (save your work first).
Or, try opening your website in your browser. It should show the website there.
Hope this helps!

I already tried those - it’s definitely something bigger. I created fresh repl projects and it’s happening on those too. Appreciate it though!

@evanluchs Maybe try switching to a different network?

this wasn’t it but you gave me the idea that helped me figure it out. My router was blocking the connection to replit.dev thinking it was unsafe. Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.