I can't get the program to run in python, can sys.exit() have any effect on this?

Question:
Hasn’t started for half a minute now, at the time of the post it’s been over a minute. Before that I imported the sys library to make sys.exit() after the code finishes its work in the if statement.
Can the hang I have be somehow related to sys.exit()?

P.S.
Surprisingly, return did not work

Replit Profile: https://replit.com/@faridunmarufi96

Bug description:
Can the sys.exit() method in python cause this result?
Because this method was used and after it the program stopped running. But now it is encoded, but still the program does not start.

Expected vs Current Behavior:

Steps to reproduce:

Bug appears at this link: https://replit.com/@faridunmarufi96/module9#main.py

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:120.0) Gecko/20100101 Firefox/120.0

Replit Profile: https://replit.com/@faridunmarufi96

*But now it is commented

Hey @faridunmarufi96!

This is a known bug, you can either switch to a non-prybar template (or modify your repl to no longer have it), or you could avoid usage of sys.exit() and exit().

2 Likes

I’m not sure what you mean. Can you clarify what you mean by prybar?

Prybar is the program that allows you to interact with your code after it finishes.

Hi @faridunmarufi96 , welcome to the forums!
To fix this Working issue, you could do what @Firepup650 said to prevent future cases and enter kill 1 to remove the Working.
Hope this helps!

Thanks for the advice. Luckily the problem has been solved. I had to endure this moment, the connection to the service was interrupted and then when it was restored everything worked as it should. Now I won’t experiment with sys.exit() anymore).

Yeah, problem solved, thanks for getting back to me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.