I cant deploy my application with autoscale

Hi guys so i created simple application with flask framework when i tried to deploy it with autoscale its not deploying it and i have this error hostingpid1: an open port was not detected i already set my application to listen to

Hi @dragonchild870 !
Could you add a port so that it works?

if __name__=="__main__":

Hope this helps!

i already tried that i even set my port to 5000 and not working , though i am not sure if this is exactly the main reason why i cant deploy it in my webview i encountered 405 but in new tab its working

so what happen is if you use it in webview it cant generate music and the whole webview will just go white and then after a few minute it will load the application from the start, in new tab it can generate music and play it there

Hey @dragonchild870!

Can you share the link to your Repl so we can take a look?

1 Like

sure https://replit.com/@dragonchild870/test1#main.py


I’ve forked your Repl and did a test deployment without any issue. Can you confirm the issue is still happening? I will be happy to bring it up with engineering if so. Thanks!