HTTPS not linking domain (SSL maybe)

Hi my repl: https://replit.com/@AbrarAkhtar/gitScore

https://gitscore.ai has been saying ‘verifying’ as the status when linking the domain for several days and then failed, but https://www.gitscore.ai is verified and working. It adds an extra https://https:// to it also. Quite urgent as site is live.

Werid, I really need to work out what is going on as my users can’t access the site.

Thanks!

1 Like

@AbrarAkhtar Could you share screenshots and/or videos of your DNS setup?

3 Likes

Here you go, would appreciate this being sorted.

Tnx,

Abrar

@AbrarAkhtar Are you using GoDaddy?

Yes I am using goDaddy. The domain variations are working fine.

@AbrarAkhtar Usually, Replit does not support GoDaddy. Can you connect cloudflare so you can use it to manage your DNS settings? It’s better anyways. I can help you connect cloudflare, if you’d like.

Yes please that would help, but I am using goDaddy for another domain also with Replit which works. However, whatever helps there. How should I go about setting up cloudflare with Replit?

@AbrarAkhtar Great. I will help in about an hour or two.

Hello there! You are actually able to use any DNS registrar with Replit. I believe your error is in Settings > Domains.

You have added the following domains on Replit:

  • https://gitscore.ai
  • WWW.GITSCORE.AI

Instead delete those items and use the following:

  • gitscore.ai
  • www.gitscore.ai

Copy the relevant records and within ~24 hours you should see that your domains have linked! :slight_smile:

1 Like

Thanks a lot, it actually works now!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.