How to upload big file to replit?

Hi guys,

i am new in using replit so I am trying to deploy an application in replit , but when I try to upload a model with 2.5 GB size its not uploading it as far as i know the free storage for free is 10 GB is there a way to upload a big file like this

Hi @dragonchild870 , welcome to the forums!
What is your file like? What programming language is the file in?
Uploading big files into Replit might take a while.

1 Like

i am uploading model.bin its for music generation i am not seeing anything no sign of uploading a file

see attached ss
image

@dragonchild870 Can you click the Upload file button on the 3 dots?

image

@dragonchild870 Is that how you uploaded file?
Could you try it?

I’ve already tried to upload the file there. It appears for a split second, but then it suddenly disappears without a trace

Dragonchild870,

How large is the file that you are trying to upload?

3 Likes

i tried to upload a file with 2 GB size

Dragonchild,

It sounds like you might be going over the storage limit on your Replit account and it’s being auto deleted. Can you confirm if this might be the case?

replit
i still have 48 GB if i am right

For clarification, your account storage is actually 10 GiB (Gibibytes), not 10 GB (gigabytes). This doesn’t really matter as GiB is actually a bit more than a GB but still is important to note.

yes, and i cant even upload a 2 GB file i tried to drag and drop it and i even try to use the upload button but nothing is working and plus i am encountering a lot of problems here in replit not just this including poetry

For clarification, the account storage is indeed 50 GiB, not 10 GiB. Pro users get 50 GiB.
(also 1 GiB is 2.4% more than a GB)

The file being uploaded is well below RAM and Storage. I guess replit can’t handle large files well maybe?

3 Likes

Yes, I tried uploading a folder that I downloaded from the Discourse repo, and it took v e r y long to upload.

I couldn’t get the program to work anyway, in the end

did it disappear? or it stayed there? i tried it again but it disappeared again without any trace

It stayed there, IIRC.

how did you upload it?

I used the Upload Folder button.


i tried folder too but the same its gone in a second this is SS of my file is it because of the file type?