How to run my own path in webview (django)

Problem description:
I make my own path at like this :

and here my own template (ndex.html) :

halaman utama

Ini halaman index

Expected behavior:
my path /utama running index.html

Actual behavior:
but i’ve got this error :

Page not found (404)

Request Method: GET
Request URL:

Using the URLconf defined in django_project.urls, Django tried these URL patterns, in this order:

  1. admin/

The current path, utama, didn’t match any of these.

You’re seeing this error because you have DEBUG = True in your Django settings file. Change that to False, and Django will display a standard 404 page.

Steps to reproduce:

Bug appears at this link:


Hey, I personally don’t know or want to know what django is! Anyway after googling one thing I found this! I hope it helps!

PS: You should probably google your problem and spend at least 5 minutes on it, Then ask on replit.


i already use django.HttpResponse and set debug=false like django document (I googling too). But when i use errohandler 404 i think that’s not a solution just give notification but not appear my html file.

Hey @TitaniaDwiandin!

I don’t see the error in the Repl you shared; it works fine for me:

If you go to the URL directly (, does it give you the same error? If so, can you please send me a screenshot of the error?