How to import/incude external libraries

I have dart source code. To do anything practical I have to have an import statement. For example:

import ‘package:flutter/material.dart’;

How do I point replit to this libary. Without it almost half of the code lines produce compile errors.

Hi @hrxv1 , welcome to the forums!
I don’t think you can develop Flutter apps on Replit.[1] You might have to use Android App Studio instead.
Hope this helps!


  1. Likewise, you can’t try to run a C++ game on Replit, because Replit isn’t a game engine ↩︎

Thank you. So what is the advantage of using replit over the many other more established IDEs?

Replit does support Dart in the “Packages” tool, but flutter likely requires you to configure your repl. Start by adding this.replit hack.

1 Like