How do I install packages with apt-get for C?

I am trying to install libedit using sudo apt-get install libedit-dev which fails, and running su -c "yum install libedit-dev*" asks me for a password I do not have. I am unable to actually install this way but it is not seeming to work.

Following this tutorial for context: Interactive Prompt • Chapter 4 • Build Your Own Lisp

Use Nix. In this case you can run

sed -i 's/];/\n  &/' replit.nix

I get this when I run and I still don’t see any changes in my IDE or when I run. Just saw your edit will look into using Nix

this was using nix. Does the library not work now?

It currently does not work, I don’t see the errors in the IDE but when I run I get this failure using the Nix template

So it’s not solved? Could you send a link to the repl?

Do not send join links, please send cover page links, I highly suggest you remove it as someone could break your repl

1 Like

What would the concern be? It isn’t my system and is a very simple project, I guess they could run my usage up but I created this project as a test for this thread.

1 Like

Maybe not for this project, but someone could permanently delete your code, here is your actual link:

People could also probably get you banned by turning your repl into something that breaks the TOS


Makes sense, thank you for looking out!

1 Like

May I ask what default.nix is there for? Replit will only run it if replit.nix is deleted.

1 Like

I just searched nix templates and grabbed the first one, I am realizing now that I should have just made a blank project.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.