Help with libraries and teams

Hi,
I had a bunch of projects that had libraries. After the conversion to Nix, none of them work.
I went in and created a new project in python. Found the packager and added in Cimage. When I typed at the top from Cimage import *
I try to run and get an error message that module is not found.

I also have java libraries from my one grad class that I need to upload again. How do I handle the path for those?

I have spent about 5 hours opening all my repls for one of my classes to convert to Nix. I’m frustrated that I have no idea about this environment and how to fix these library issues. Can someone post a video on how to do this?

3 Likes

Hi there! Could you try using pip to install the libraries?

2 Likes

I have no idea how to do that. I was using one of the built in packages. I thought it automatically installs it. I don’t know where to change in the nix file the fact that it is there. I haven’t even attempted the java programs yet. I’m fine with using BlueJ and importing there but I want my students to be able to work outside of class and this requires the library to be imported. For java, where would the jar file go in the whole folder structure and how would you use pip to install?

Hey @BethStoudt!

Could you send me the link to the Python Repl that is giving you the “module not found” error so I can take a look?

1 Like

It is part of a team. Will that link still work?

https://replit.com/@Prog2Block2ADay/Image-Processing-v2

@BethStoudt Can you try entering pip install climage into the Shell?

Capture

That didn’t work. Not sure what this means. It looks that it is already in hat library folder?

Did you try import cimage and see if it works?
Is the library called ‘cimage’?

Ok… can you try entering poetry add cimage into the Shell?

That didn’t work. The library is called cImage. I have it over here with the packages installed.
Capture

Replit’s packages are quite unreliable, so it’s generally a good idea to use pip or poetry.

@BethStoudt Can you try this and see if this works?

Just to be sure, could you try removing it (pip uninstall cImage) and installing it again (pip install cImage).

Also, if nothing in the Repl is confidential, is there any chance you could create a public fork so the community could take a look under the hood (so to speak) :smile:

2 Likes

I still get the error “no module cImage” :crying_cat_face: I’m getting very discouraged here.

Try @MattDESTROYER 's idea.

I tried that and it isn’t successful. Since it is in my team I will make a copy of it and share that.

Oh dear. I have no more ideas, unfortunately.
Ok, last one, this might not work: enter poetry install cImage into the Shell.

https://replit.com/@BethStoudt/Image-Processing#main.py

1 Like

@BethStoudt Does this work?