Help with a simple test

Thank you so much! I thankfully found one replit that worked and was able to copy those files. If only I could fix them all at once - I have about 50 that I copied that all have this problem for some reason. They all took forever to load and say they were converting to Nix.

Hey all!

We are aware of this issue and are looking into it. I will post any updates here.


I merged the duplicate posts on this issue. If you are part of this thread but aren’t seeing issues with I/O tests, please let me know and I’ll unmerge your post.

1 Like

Hi @ShaneAtReplit - thanks for getting stuck into this one! Yes the problem relates to IO tests. Unit tests were initially unavailable with the message “not supported for this language” although the workaround provided by @NuclearPasta0 does work to enable Unit tests.

I have the same issue with all repls I create for my students in classrooms.

1 Like

Thanks for posting this. It is a lot more code than what was originally in those files.
This worked for my I/O tests.
I have to update the code in these files for every replit assignment I have???
Thanks again.

All Python team repls made recently (since their update that broke this, not sure when this happened) would have this issue. Until replit fixes it, all new Python team repls will continue to have this issue. I don’t know that they will be able to provide a solution to batch update the broken repls, so afaik, the only solution would be to manually update each affected assignment.

I created a unit pinned at the top of my EDU team and walked my student thru how to do it for their existing repl’s.

Meanwhile, go into your master assignments and update them manually. At least for the ones you’re using until replit posts/discusses a fix.

I’m having the same issue as everyone else, but when I tried this workaround the output from running tests now shows input prompts as part of the output. This ends up breaking tests because the outputs becomes too long and the actual output I’m looking for gets truncated off the end. Any ideas? I am trying to assign a homework for students with auto-grading tests, which was the entire reason we switched to replit for this semester…

Yes! This worked perfectly. Now I just have to edit my next project before any students forks it to work on it. Thanks!

Thanks a million for this! Lifesaver.

Thanks again for sharing this. I am getting “Actual Output” now which is helpful, but if there are errors in the output, it will not always show all of the output. Also, in the “Difference” box, it shows everything that has an error in it on one line and does not show correct output … actually, I have not been able to figure out the pattern … sometimes it shows errors and correct output, sometimes just the errors, but always stretched out on line one with no new lines.
If you have any thoughts or tricks to help … I’m all ears.

For my “AP Computer Science Principles” course, my I/O tests I’ve set up are not working.

The test results are saying the “Actual Output” are my input values vs. what is actually being printed as the output.

My “Introduction to Python” course, the I/O tests work fine.

Are other teachers running into this? I don’t know what to do to fix it. I’ve tried making a brand new assignment and rewrote the I/O tests, but they still fail every time.


You are not the only one experiencing these issues. I think someone suggested using the old Python template instead of the new one to fix the issue.


Problem description:
This is in regards to autograded projects on Replit Teams for Education. Autograded projects with Input/Output tests that are migrated to the new Nix environment are not working.

The replit and replit.nix files are mostly empty. When students run the tests, tests cannot detect any input/ output.

Expected behavior:

Actual behavior:

Steps to reproduce:

Bug appears at this link:

Device (Android, iOS, NA leave blank):
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Hacker, Pro Plan):

Having the same issue, I hope there is a resolve for this soon!