Help me, one of my package functions don't work!

well… I need help. When I tried the code separately it works perfectly fine!
Repl link:

#Snippet is way too big, Even discourse doesn't let me create a topic with the snippet

Slightly off-topic question (you can pm me the answer so that it doesn’t get flagged):
How on earth did you code that!? Looks so complicated (wow!). Great job, btw.

Anyway, for your issue, which function has the issue?

the options() function, sorry I did not give more context!

I see that you have defined the options function twice, and that they are different “versions” of similar code. Is this expected behavior?

1 Like

no, this i not. I probably copy and pasted it.
Just choose one of them,sorry if I caused some confusion!

if so, keep only one (bc if you edit one, the other might cause overlap and lead to future problems).
I’ll see which one has more functional code
EDIT try keeping the second one


Yeah I kept them, I tried making modifications in a new repl, but it doesn’t work!!!

Hello everyone! Sorry for the inconvenience caused!
I am terribly sorry to tell you all that
I named a list the exact same as the function :rofl: im so sorry for putting you in this situation.
:sob: I hope you all accept this apology, sorry that i missed out something as careless as that!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.