Gunicorn web server not launching

I have a flask web app.

I previously hosted it on Heroku, and now imported it to Replit.

When I run the application as it is, it gives me the following error:

flask db upgrade; gunicorn microblog:flaskapp
sh: /home/runner/denselayersalpha/venv/bin/flask: /Users/amanagarwal/Documents/PROGRAMMING/denselayers_beta/venv/bin/python: bad interpreter: No such file or directory
sh: /home/runner/denselayersalpha/venv/bin/gunicorn: /Users/amanagarwal/Documents/PROGRAMMING/denselayers_beta/venv/bin/python: bad interpreter: No such file or directory
exit status 126

I have no idea what’s going on, could someone explain what’s happening? I’m happy to destroy and re-initialize the venv if that’s what it takes!

I was going to manually scan through your code but then I looked at what an absolute unit it is and decided I need to ask: where the error is, that is, if you could be more specific

1 Like

Hey @mngrwl, welcome to the forums!

Please send a link to your Repl. Make sure it’s not the invite link though, as that means anyone could edit it.

If you don’t want to send a link to your Repl, please send a minimal Repl that reproduces the issue or a code snippet.

1 Like

I’m 90% sure this is it


Hi, it’s denselayers_alpha (as @bigminiboss mentioned below).

The statement above is run from the Procfile. It seems to be looking up some files that have my personal computer’s paths on them, but I don’t know how to update them.

try after running in shell

rm venv/pyvenv.cfg
1 Like

Hey, thanks! I tried it, but it doesn’t work :confused:

I still get exactly the same error.

What command are you using to run it?

1 Like

Just the big green RUN button… I believe it refers to the command in the Procfile!