GroupyAPI package not importing to Python in Repl

Hello! I keep getting the following error code when I try to install the GroupyAPI package in Python. Any suggestions?

Try using pip instead. Like this command pip install GroupyAPI. Poetry is really buggy.

1 Like

run in shell

pip uninstall typing

typing is now built-in, and the package is deprecated

Thanks for the help! I tried that, but it gave the same error. Any other suggestions? Thanks again.

could you link the repl or a minimal repl which reproduces the issue?

Sure! Here it is: If you can’t see it, lmk and I’ll publish it…I haven’t been on since it transitioned from, so I forgot a lot of how this works.

:wave: Hello!

Here are some methods I’ve found to help the situation

Method 1

Using the pip install code in the system function from the python module ‘os’. Increase’s loading time per run yet decreases the chances of bugs happening.


I see that there is an error in importing the python module ‘GroupyAPI’ . Perhaps this python code to use will help :

from os import system as shell
shell(‘pip install GroupyAPI’)

Method 2

No loading when re-run. There will only be loading in the shell. This uses the pip install code directly in the default shell


Perhaps try running this in your repl’s shell :

pip install GroupyAPI

Thanks for the help, but neither of those methods worked. I think I’ll just try something else. Thanks again!

I think I finally found a solution that worked. Apparently, the community has been aware of an issue with the typing module for a while: AttributeError: type object 'Callable' has no attribute '_abc_registry' · Issue #131 · ethereum/eth-abi · GitHub.

My Solution

  1. In the bash terminal, cd into the directory containing the typing module.
  2. Enter rm
  3. Enter pip install GroupyAPI
  4. Watch incredulously as it successfully installs.

So there you go! This fix continued even after I reloaded the repl. Oh, and I also accidentally upgraded to Nix by installing some sort of vim tool.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.