GPT 3.5 not giving errors

Recently I have forked the replit templete for GPT4 and I was getting this error so I changed it to GPT 3.5 Turbo and I still get the issue. So I thought it had to do with the new replit bitrate limit so I tried it on another account and I still got the issue even though it said there was no usage with the bitrate. Did I do something wrong or is it just broken?

Hi, can you post the link to the Repl?

You probably exceeded the quota for your Open AI account, not your Replit account.

You will need to pay some money to continue using the AI. Otherwise, if you don’t want to spend any cash, you will have to wait for a while till you can use it again.


Ok, That makes more sense since I haven’t been able to use ChatGPT since February


The error I got was:

It looks like you need to make a secret with the key inside. To do this, go to the tools menu, click secrets, and create one called “OPENAI_API_KEY”, and put your key where it says ‘value’. It should work then.

that happens for you because the secrets aren’t carried in to your temporary copy of the repl on the spotlight page. If they are you’d be able to get their api key and abuse it


But the error happened when I viewed the public repl.

That… was UMAR’s point. Secrets are not available on the cover page, and never should be. (Unless you own or collaborate on the repl that is, then cover page is same as in-editor)

1 Like

Each account that visits the spotlight page will see a different temporary fork of the original repl. Changes made when you run the repl won’t appear for anyone else.

1 Like

Then how did the original chatGPT work?

Because it’s… OP’s original Repl?

@UMARismyname’s point has already been made clear. Replit will create a copy of the Repl without any Secrets and all the stuff that should be hidden from any users.


but I put in the key and it displays a different error for me

Ok, sorry for the misunderstanding.

I am also getting the same error , did you got any solution???

It was just my OpenAI Account was rate limited

If it says

You exceeded your current quota, please check your plan and billing details

Then you will need to pay to continue using the API on that account.