Good/working HTML/CSS/JS validators?

So recently, I added huge updates (IMO) that change a lot of things. Not surprisingly, I screwed something up in the process, and no messages are sending. I’ve been getting these two errors in dev tools:
and it worked before. I think that the second error is caused by the first, so I tried to find the error at line 40. There was no error there! This is line 40: margin: 0.25rem; and you can see that there is nothing too different about this line. This means that all the lines are now messed up and I can’t find the error. So I’ve tried to find sooo many validators that it’s depressing because I manually looked everything over and I can’t find a problem.

Are there any good validators that could hopefully find what is causing this issue? The only problem that the validators I’ve used found was that there is no lang attribute in the <html> tags.

Also if you want to help me, can you check index.html over?

1 Like

One thing that probably doesn’t help is this line:

<script src="/"></script>

There’s nothing hosted at

(This is what’s causing the second error.)

1 Like says to add that for client stuff.

Yeah, but you would need to download the actual library and put it in a folder called for that to work, try replacing it with this <script src=""></script>.

Wait, nvm… it does seem to be hosted… I guess it’s part of the npm package?

The second error is because on line 157 you have an extra }.

1 Like

Nice, that works. Any reason why the error tells me that it’s on line 40?

Dunno, I opened the page in a new tab in Chrome and it just told me line 157 had an unexpected } :man_shrugging:

So this is a bug? I might start a new topic on bug reports because this has happened to me on other repls. I used Replit’s dev tools.

Replit’s dev tools are a little clunky and buggy, I always just open in a new tab and use browser dev tools to be safe/sure


I wish I could do that, but my school says it’s a no. I know some people use dev tools on Replit because of reasons so this is very annoying and it’s probably a quick fix.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.