Godaddy custom domain cant set txt

Question:
I cannot get my domain chat.keyplays.co pointing to my private repil

  1. i set cname and it chat pointing to xxxxxxxxxxx-1dc4c11153d6.id.repl.co.
  2. I try to set txt to replit-verify=xxxxxxxxxx-1dc4c11153d6
    But I get Record name chat conflicts with another record.

I dont know what to do next

Hey @malcsilberman!

Thank you for reporting this, we will take a look.

1 Like

As a temporary workaround, set up your domain with Cloudflare as it will allow you to add both a CNAME and TXT record on the same domain.

2 Likes

I need to retain godaddy as my main domain uses website builder - i only want a subdomain pointing to replit. It is setup correctly with the right cname - I have triple tested this but it never resollves properly. Rather it - see screenshot as to where it resolves too;

We have been able to identify the issue as a high-priority bug and have created a post for updates: Custom domains fail to connect - #2

1 Like

sill got the issue

@ShaneAtReplit when will this be solved - its nearly 2 weeks and its a critical thing for any hosting. I have to consider moving elsewhere if not solved quickly.
Many thanks

I will follow up with the team regarding the investigation. We should be in a good place now to work on a fix, although I’m not 100% sure. I will post all updates to https://status.replit.com/notices/ecfncsbq0ze2juvq-custom-domains-stuck-verifying regarding the issue.

1 Like

I see this update but its really strange 1) why has this only now been discovered as a bug since people should have been using this since you began? 2) lots of other ‘hosting’ companies do this eg. I do it on google cloud for some sub-domains - why is it so difficult for you guys to sort out?

Upon investigation, we have identified that this issue is related to CNAME flattening, where various DNS resolvers automatically add an A record along with the CNAME record, preventing us from verifying the domain. We are actively working on finding a solution to address this on our end and resolve the verification issue. We apologize for any inconvenience caused and appreciate your patience as we work towards a resolution.

We believe this to be caused by a recent change on our end, which wasn’t the case originally. However, we are still unsure how to resolve this an are still looking for mitigation strategies.

1 Like

Also having this issue!! Please fix asap.

@ShaneAtReplit any update here?!

I apologize for the delay in replying, I thought I went through all of my domain-linking posts and posted the update we made, but I had forgotten this one!

We have concluded our investigation of this issue and have posted the update here:

1 Like

Thanks @ShaneAtReplit , I ended up changing over to cloudifare and was able to get the domain linked via cname/txt record, but still having issues. I have a static site / repl I built, and I linked a custom domain to it (which has been verified). Now when I go to the URL, I get the following:

What am I doing wrong? I just want the website to work normally when navigating to it in the browser. I really need this up and running so any help would be appreciated. Do i need some sort of separate hosting package?

Can you please send me the link to your Repl so I can take a look?

@ShaneAtReplit DMed.

1 Like