GLIBC Python version incompatibility

version `GLIBC_2.38’ not found
required by Python - no idea how to fix this or how it happened
my app no longer works

2 Likes

Hello @EdwardCahill!
Could you please provide the error you have gotton? You can do this by screenshotting, screen recording or copying the console’s content.

How to copy Console output

You can use CTRL + Shift + C, or highlight the text, right-click and press Copy.

I’m getting the same thing right now. I haven’t changed anything in my environment since earlier today and it was working then.

This is the console output when running the replit. I’m using python.

Packager:

--> poetry env list --full-path
/nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash)
--> poetry env list --full-path
/nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash)

Run

/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libm.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/3wvj2nbynari4iirc4yx3mhf26hbjr9s-libxcrypt-4.4.36/lib/libcrypt.so.2)

edit: added the packager section of the console

/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libm.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)

Question:

2024-02-07T01:43:38Z info: Deployment: a60c286e-1993-44c3-9223-9517e9746e21
2024-02-07T01:43:38Z info: Build: c7773d6f-bde4-4f93-8e2c-5615d9f04113
2024-02-07T01:43:38Z info: Connecting to builder
2024-02-07T01:43:41Z info: Builder connected
2024-02-07T01:43:42Z info: Installing packages
--> poetry lock --no-update

/nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash)

exit status 1

Repl link:

[tool.poetry]
name = "lstm-bot"
version = "0.1.0"
description = "A brief description of your project"
authors = ["Myself"]

[tool.poetry.dependencies]
python = ">=3.10.11,<3.12"
numpy = "1.23.5"
pandas = "2.0.3"
ta = "0.10.2"
torch = "1.13.1"
scikit-learn = "1.2.2"
lumibot = "3.0.6"
#alpaca-trade-api = "3.2.0"

[tool.poetry.dev-dependencies]
pytest = "6.2.4"

[tool.poetry.group.dev.dependencies]
ipykernel = "^6.29.0"

[build-system]
requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.core.masonry.api"

Question:
how do I fix this

poetry env list --full-path
/nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash)
--> poetry env list --full-path
/nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash)

I’m getting the same thing. Here’s another recent post about it.

This is not an error.

Seems to be something a few people have been getting recently.

I am having the same problem too. GLIBC not compatible using Python.

Packager:

/nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash)
--> poetry env list --full-path
/nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash)

Run

/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libm.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/3wvj2nbynari4iirc4yx3mhf26hbjr9s-libxcrypt-4.4.36/lib/libcrypt.so.2)'

The nix package is still on version 2.37

I found out what the issue is, you have to delete the .replit.nix file

Hello, this issue is being fixed, in the meantime:
Click three dots and Show hidden files, then open .replit file.
Then, change the channel variable to "stable-23_11", and refresh. This updates glibc version to 2.38, fixing the problem.
This configuration just updates System dependency packages to newer versions so it is fine to keep it after the bug has been fixed, assuming the newer versions are compatible with your code.

2 Likes

Problem description

I have been running a python program without problems for over a week. Today, I started receiving the following error:

--> poetry add pytz requests google-auth gspread numpy pandas
/nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash)
exit status 1

/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libm.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/3wvj2nbynari4iirc4yx3mhf26hbjr9s-libxcrypt-4.4.36/lib/libcrypt.so.2)

I updated my Nix packages using the following commands:

nix-channel --update
nix-env -u '*'

The program now executes, but it continued to generate an error:

nix error: building nix env: os.Readlink() channel: readlink /home/runner/.nix-defexpr/channels/nixpkgs-stable-23_05: no such file or directory

I tried running the following command, but it made no difference:

nix-channel --add https://channels.nixos.org/nixpkgs-23.05-darwin
nix-channel --update

Any ideas on how to address this?

Expected behavior

Program should run

Actual behavior

Generates the nix errors noted above

Steps to reproduce

Run program and wait for it to execute

Browser

Chrome

OS

Mac OS

Device if mobile

N/A

Plan

Core membership

Thanks so much that did the trick

are sure it will work?

Thanks. Fix the error.

you’re a genious, thanks for you’re help !!! It’s ok right now

Same error, same solution. I imagine Python is broken across all of Replit right now?

Hi folks. We pushed an upgrade that seems to be causing this issue. We’re going to revert the changes shortly.

Hi @voxivox. We pushed an upgrade that seems to be causing this issue. We’re going to revert the changes shortly.

1 Like

Thank you. I used NuclearPasta0’s suggestion along with some tinkering to get things working. Once you revert, can you please provide some notes on what else needs to be adjusted in the config or packager files?