Github syncing issues

Question:

I had my Github account quit syncing on Replit with my repls. I had to delete Replit from Github to try and get it to sync again. I had a repl that I forked to begin a completely new project. I updated the remote repo name and created the new repo via the Replit github interface. It created the new repo. If I tried to sync it though, it remembered the old repo that it was forked from, also, when I tried to commit new changes it said:

$ git commit -m "initial commit"
Author identity unknown

*** Please tell me who you are.

Run

  git config --global user.email "you@example.com"
  git config --global user.name "Your Name"

to set your account's default identity.
Omit --global to set the identity only in this repository.

fatal: unable to auto-detect email address (got 'runner@27e31fd9d4cc.(none)')

When I tried to just push to origin main it pushed the old files from the original fork, not the updated files. I couldn’t do what I needed to do via the replit github gui but I don’t know what the heck I should have tried to set the git config --global user.email "you@example.com" to or if I should have even tried to. I am in this position because Replit quit syncing with github for unknown reasons and it has been very frustrating since.

I deleted the .git folder and the remote repo. I then git push origin main my initial commit. Seems to have gotten it to work at least for now.