GitHub integration is asking me to push and pull at the same time

Bug description:
GitHub integration is asking me to push and pull at the same time

Expected vs Current Behavior:
I should be able to either pull or push

Steps to reproduce:
Have a repl synched to a GitHub repo, edit both the repl and GitHub repo.

Bug appears at this link:

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (iPhone; CPU iPhone OS 16_4_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.4 Mobile/15E148 Safari/604.1

Replit Profile:


You should commit your changes first, if I memorise it correctly


According to the screenshot, they must pull changes before they can push their changes. But they must push their changes before they can pull their changes.


On that note, closer inspection of the image reveals that’s not quite what it’s saying here. See if you have a Commit button you can press further down on the UI (you might have to provide a commit message), and see if it will let you pull after you “locally” commit the changes.


this has to be a solve. :confused:

1 Like

I’m very confused, it’s still not letting me push or pull. Thanks for your help though :+1:

1 Like

See if you can provide a commit message, and then Stage and commit all changes

1 Like

Yes, I did that, where it says “Testing pls?” But below it says “Cannot push due to unpulled changes” and vice versa

Try opening the Shell and running these commands:

git add .
git commit -m <some commit message>  -a
git pull origin main
git push -u origin main

This should:

  1. Add any new files to GIT
  2. Commit any changes replit missed
  3. Pull from github
  4. Push to github

(Added git add . from Quantum’s suggestion)


Its better to do first git add . so that newly created files are also commited

Sorry if I’m just majorly missing something-- but what should I do? It seems like it’s not letting me pull because the replit cache file updates itself after I push.

See if there’s already a .gitignore file, if there’s not, make one. Then try:

git rm -r --cached .cache

and add .cache/** to the .gitignore file.

Also, I don’t believe this is your fault, it’s just replit having a weird quirk ¯\_(ツ)_/¯

1 Like

mkay so i made a .gitignore, and it looked like it was going to let me push

But of course replit doesn’t want that to happen lol:

Try using the commands I originally posted to pull/push from Shell:


That worked! Thank you so much :))

The __replit_disk_meta.json file is still saying it should be pushed, but I’ll ignore that for now :wink:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.