Git panel is not working

Bug description:
when I opened the git panel i got this error:
Failed to start the Git2 pane.Error: UNKNOWN_NOT_GIT

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36 Edg/112.0.1722.58


I’ve only ever seen that error when trying to break replit. Do you have a git repository initialized in your repl?

I am getting this same error

You need to initilize a github repository.

github is not the same as git… People don’t need to use a proprietary hosting service for it to work.

1 Like

I’m also getting this. Git pane was working 2 days ago and now all of the sudden it throws this error, and I haven’t touched anything in between. Won’t even let me commit or push through the shell because “another git process seems to be running”

Try running pkill git in the shell

Tried this, didn’t do anything. Here’s the error message when I try to commit:

"fatal: Unable to create ‘path/to/repo/.git/index.lock’: File exists.

Another git process seems to be running in this repository, e.g.
an editor opened by ‘git commit’. Please make sure all processes
are terminated then try again. If it still fails, a git process
may have crashed in this repository earlier:
remove the file manually to continue."

Then try rm .git/index.lock


Perfect that fixed the shell issue thank you! Git pane still throwing same error but at least I can commit through the shell

Update: Git pane is working after that command

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.