Getting Error After Replit Automatically updated the new environment


Repl link:

code snippet


Try running pip install flask in the Shell tab.

1 Like

Ok, this error is happening somewhere else as well, seems like a Replit issue:

It’s a bug caused by the Nix migration IIRC. Here’s a fix to pass around:


I tried pip install flask then i got this new error

Seems like pip install flask is working. Try pip install telegram.

1 Like

Ok, I don’t know anymore.

Maybe pip install -U telegram?

1 Like

I tried this but still the same Import error

Hey, @GSV-GROUPGROUP welcome to the forums!

Can you please provide a link to the repl? This way it is easier for staff and members of the community to help you!

Also see this guide on how to share your code:

1 Like

Try running poetry update, looks like the telagram package was not the right one, but you already have the right one in your pyproject.toml.

Can you please explain more how to update poetry… Not a coder :pray: :pray:

Run the command in shell… might need to pip install first tho


Thank you so much… finally Bot live but still got some issues


But i didn’t receive any text in telegram channel