Folder items not loading in content

the fork works i wonder why it only works

Hm, then use the fork instead.
If your problem is solved, please mark this post as a Solution as it has solved your problem, so that others with the same issue can solve their problem faster.
cc: @Firepup650 @UMARismyname

It could still be beneficial to identify the issue though.

Happened to me before. A bit buggy, it works sometimes. The code is correct, might be Replit’s problem.

For some reason, Replit .dev deployments don’t serve images. is not for deployments.

I am talking about their servers.
This is a CORS issue

That doesn’t make any sense to me, isn’t CORS supposed to be cross-domain? That shouldn’t be an issue on any given site. (Because it has one domain)

CORS is the system which manages CORS Requests.
Replit is either not exposing these or is not even serving them.

This issue happens with Susha Radix and .dev sites.

Again, wouldn’t that only be an issue if it was cross-origin? Same origin (so one repl with one dev site) shouldn’t hit it.

Please check out Cross-Origin Resource Sharing (CORS) - HTTP | MDN

Or try this on your own.

You usually will get CORS errors if you try and get a file that you can’t access if not 404

I feel like this backs up what I was already saying:

Only if it’s from a different domain, otherwise the error will be different, it has to be (CORS literally doesn’t apply to same-origin requests).


@Chase305 this might be a bit random and I know the problem is solved with the fork but could you rename Flags/ca.png to anything random and then change it back? on some html/css/js repls files are randomly not found by replit (happened to me) but renaming + changing it back helps. maybe this is what’s going on, can you try that?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.