Flowise install

~/Flowise-1$ npm install -g flowise
npm WARN ERESOLVE overriding peer dependency
npm WARN deprecated cross-spawn-async@2.2.5: cross-spawn no longer requires a build toolchain, use it instead
npm WARN deprecated @babel/plugin-proposal-class-properties@7.18.6: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-class-properties instead.
npm WARN deprecated @npmcli/move-file@1.1.2: This functionality has been moved to @npmcli/fs
npm WARN deprecated vm2@3.9.19: The library contains critical security issues and should not be used for production! The maintenance of the project has been discontinued. Consider migrating your code to isolated-vm.
npm WARN deprecated highlight.js@9.15.10: Version no longer supported. Upgrade to @latest

added 1527 packages in 2m

239 packages are looking for funding
  run `npm fund` for details
~/Flowise-1$ npx flowise start
    Error: libuuid.so.1: cannot open shared object file: 
    No such file or directory
    Code: ERR_DLOPEN_FAILED
~/Flowise-1$

Hi, @justcallmeCW! Your post is pretty unclear. Do you need help with anything?

3 Likes

@bobastley I’m trying to install FlowiseAI on Replit so I can use it in the cloud instead of locally. It’s already locally running on my laptop and I deployed on Railway…BUT I really love Replit and what they are doing. There is documentation on Flowise from the team on how to install on various places such as Railway, Render, Azure, etc. But the Replit doc doesn’t seem to work. I 've noticed a few people on here are having the same issues. Did tech years ago and changed careers but I missed tech too much not to come back…but being away so long my learning curve is pretty steep right now.

Just want to get this running. A bit frustrated. Thanks for replying! :slight_smile:

Flowise and Replit Docs

1 Like

If you create a replit.nix file with these contents, you’ll be able to get past the error and run:

{ pkgs }: {
	deps = [
		pkgs.libuuid
	];
	env = { LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath [pkgs.libuuid]; };
}

We’re working on something that will do this automatically so you don’t hit it. Sorry for the inconvenience, it’s a pretty hard fix to discover on your own.

1 Like

I am running into same issue. I update the .nix file with what you posted here, but still getting the error. Is there anything else that I need to do?

I have tried to install Flowise to Replit (using the browser version) many times with no result. But then I tried to do it in the app (MacOS), and everything worked perfectly. It looks like the problem was in the browser ( I used Safari).

Safari has known issues with Replit, see this topic for details: