Flask replit not working

this code is working on my laptop, but it does not work in repl, it worked in the past but now it doesn’t.
please help
it says we couldn’t reach this Repl

Welcome to replit ask! Are you listening on

yes i am
and port 8080 and i tried 80, 8000 and 5000

Any other HTTP servers running?

yes there is other http servers running

Can you please provide some errors/a better explanation of your problem?

there is no errors, the only problem is this:

Did you run your repl? What does the console say?

here is what it says, it seems no errors:

Ah poetry breaking. Set guessImports to false in .replit.

there is not guessImports in poetry.lock.

Good thing i never said it was in poetry.lock XD

Also, looking at your code, it is probably best if you use a simple db like replit db instead of json files :slight_smile:

there is not .replit files either…

when i try to create one it says it already exists

It is a hidden file, you can show them by using this:

should it be like this ?

it’s still not working it’s the same problem

Uh-oh, I just realized your repl is very old, and does not have the stuff it should in .replit. For now just delete the file. Try migrating by adding ?migrateNonNix=1 to your url.

Also, it should be equals, not colon.

PS: Please edit your post instead of sending multiple messages.

Would fork help? Or will it retain the same old repl version?

same problem i tried a lot