Flask app stucked on redeployment indefinetely

Problem description:
I am trying to redeploy my Flask App, and is stuck with the loading for hours nows. Even If I close the replit and come back stays the same.

Expected behavior:
Should move through the stages of deployment and deploy the app

Actual behavior:
Stuck in loading

Steps to reproduce:
Not sure, I just clicked redeployed (worked multiple times in the past)

Bug appears at this link:

Both on Chrome MacOS and iOS app

Have you tried reloading the webpage / closing and reopening it? Many times when this happens it’s because Replit was not able to connect with the servers. :smiley: hope this helps!

Thanks, yes I tried it many times :confused:

1 Like

CC @ShaneAtReplit

Looking into this now!


Does the issue persist if you do this from another Repl?

1 Like

No, I am able to deploy in other replits.

Now the button redeploy became active again, but when I click it says a deployment is in progress

Does it still say “in progress”?

Yes, now it is back to the forever loop loading

Hey – we’ve identified the issue and pushed a fix. You can expect this to start working by the end of today.

Please let me know if you try tomorrow and it still isn’t working!

1 Like

It is back to working! thank you!

Great! Lmk if you run into issues in the future. :slight_smile:

1 Like

Getting another issue, when I try to deploy “Unable to connect to container in 90s”

Created a different issue as it is also in other replit:

Feel free to close this one :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.