Firewalledreplit - Output window not connecting and shows an error

This video was taken on a machine hitting firewalledreplit.com with no web filtering or firewall enabled.

Might help someone investigating this issue.

Is there a status page or something that shows progress on this issue anywhere?
We were looking into using firewalledreplit for our students (paid for) but we have not been able to use it for almost a week now due to this issue with the firewalledreplit instance.

Which makes me question the reliability of using it in the classroom.

Please avoid pinging people who haven’t participated in the topic @Mr-PP5, especially Replit Staff.

2 Likes

After 2 weeks of firewalled replit still not working and with no statement on the issue with the “output” issue above on non managed devices and on unfiltered internet, I have decided to move away from using replit and to voice my concerns with ever using it at a school trust level.

What do you plan to use? We are looking for something new as well.

1 Like

Is looking like a good candidate, im also looking at using the below

https://pythonpad.github.io/docs/sandbox.html

failing that local install of Jupyter Notebook or an immutable virtual machine scenario.

Just out of personal curiosity I’ve just checked and firewalledreplit.com is still not working.

Still does not show any output in the output window.

Showing the same error as above.

Have you tried consulting with your IT dept to see if there are any blocks?

Please try whitelisting sp.replit.com, port 5900, and replit.dev.

Hi @jesse ,
I’m an ICT network manager and can confirm these devices do not have any firewall restrictions and the error is shown on multiple devices using multiple internet connections that are unrestricted and unfiltered no firewall is in place, the internet connection is open.

Thanks
Paul

Still not working, any replit that requires an output window still fails to connect on firewalledreplit.com

on multiple devices
on multiple open and unfiltered internet connections

repeated websocket issues in browser console

replit.com works correctly (cannot be used due to safeguard concerns with students)

Please can someone test the below replit, its a blank python (turtle) template

This needs to be tested wit firewalledreplit (NOT normal replit.com if you fork this project it will try and run it at replit.com please add firewalled in front of replit)

The output window never connects and this is on an open internet connection on a personal device.

Almost three months in and any replits I create that require an output console do not work with firewalledreplit.

I’m currently at home with two internet connections on three separate home devices and all three fail to run any python replits that requires an output eg python with turtle, pygame, simplegui etc.

@Mr-PP5 At first, it shows an error, but after 2 minutes, it fixes itself.



@python660 Thankyou for spending your time to confirm its showing an error, unfortunatley I cannot replicate the output window showing after 2 minutes, what were your steps to reproduce it working after 2 mins? did you leave the replit running for two minutes then click try again?

I have left the replit running for time periods of 5 minutes, 10 minutes, 30 minutes and even an hour and they all report back with the same error.

Before Replits infrastructure upgrade around the end of November firewalledreplit worked correctly and was ideal to use for students.

Yes, I just left it up.

That is very interesting. I might investigate further tomorrow, but right now, I need to do my homework.

2 Likes

Just a quick update - this issue is still showing

Hi there, could you check if the replit.dev domain is unblocked? The domains were switched.

This is failing on devices where no hardware or software firewall is involved and has been tested on multiple devices including personal phones on mobile data.

Just received an interesting email

In December we announced that Teams for Education was being deprecated. This includes Teams for Education and related features like Firewalled Replit and Privacy Limited Education Accounts. Firewalled Replit was used by some schools to allow access to Replit though local firewalls and Privacy Limited Education Accounts were used for some student accounts to allow signing up without an email address.

This is why firewalledreplit isn’t working and isn’t going to be working

So… there goes Replit as a platform to teach coding? At least when firewalledreplit is needed to deal with the next generation of hacker kids lol