Firewalledreplit - Output window not connecting and shows an error

Problem description

firewalledreplit - Output window when using tkinter or pygame shows an error “Error connecting to the server”
Have tried numerous browsers and user profiles, mobile phone and other devices.

Has worked previously and now seems to be affecting all students.

Have tried closing the output window and reopening, clearing browser cache and incognito window

Seemingly works correct on replit url

Expected behavior

Output window to show output instead of the error

Actual behavior

Shows the error “Error connecting to the server”

There was an error connecting to the server
If you see a browser error, it’s possible that your ISP have security settings blocking the URL. Please contact your ISP and ask them to unblock the URL above. Here are the support links for common ISPs:


Try again

Steps to reproduce

goto firewalledreplit

main replit domain works
firewalledreplit shows the error




Windows 10

Device if mobile


Free tier


I am not aware of the Android App but I think you can refresh or reinstall the app.

For the repl that you linked, I copied and pasted your code into a Python Data Science template instead of a normal python template

and it shows the output.

And for tkinter and pygame you could try each of their templates as well.

1 Like

I’ve tried templates and they also make the output window snow that error, only on firewalledreplit.
Replit domain loads them correctly

We have to use firewalledreplit to stop students bypassing web filtering. and .co have been whitelisted, are there any other URLs needed for firewalledreplit to work correctly?

Did you try clicking the try again button as well? And running multiple times?

Sometimes it would bring up the output only to show the error connecting to the server message, but then I would click the try again button and it would then load the output, or sometimes I would have to run it a second time before it worked.

This is all pertaining to normal replit, not firewalledreplit so I’m not entirely sure if this is useful. I’m just going based off of how other posters (1,2,3) have been reporting the output window not appearing as well.

And to answer your other question about other urls I dont know I’m sorry, maybe someone else could help with that.

I’ve tried clicking the try again button numerous times, deleting browser cache and running in incognito mode, I’ve closed the outpit window and reopened it and it still shows the same message.

Firewalled replit now uses the same Output domain as normal replit: * This domain is probably being blocked.
If it is unblocked, try clicking Try again while the program is running.

1 Like

I can also confirm is also whitelisted.
Clicking retry again doesn’t achieve anything for me and still shows the same error.

I have no idea then. Hopefully staff will look into it.

After allowing “Inspect” policy on the chrome browser I can see the websocket is initially being allowed through but then gets closed with an error “websocket connection to 'wss://” failed. has been whitelisted for websockets as well

just to confirm works correctly shows no output and generates the above wss:// error has been blocked due to students using projects that bypassed our web filtering.

1 Like

On a machine which bypasses our web filter (so its completely open) I get this in the chrome browser (with no extensions installed)

On my mobile phone I also get the same error on the output window

My mobile phone is using a normal 5G data connection to prove its not network related to the school infrastructure

If you fork your repl and run it, can you see the output on the forked version?

Thanks for the reply, no a forked versions also gives the same error on the output window, a blank python (turtle) template or blank pygame template (all created in firewalledreplit mode) all give the same error on the output window, this has also been tested on my mobile phone using its 5g data network and on my home pc using a different internet connection.


If you have a firewall, you will need to unblock *

Sorry but I feel like I keep repeating myself in this forum, * (as stated above) is whitelisted when I’m at school.

I have also tried on my mobile phone on a 5G data connection and also on my home computer using a different network both of these devices are not filtered.

When I see these errors I see multiple websocket errors in the browser but only when using the firewalledreplit instance.

These websocket errors have domains that are whitelisted and not inspected when I’m in college but the errors also appear when I’m using an unfiltered connection either on my phone or my home computer.

Hey @Mr-PP5!

The issue is not an issue related to DNS/firewalls. You will have to wait for staff to respond and eventually fix the issue, nothing can be really done right now.

1 Like