"FileNotFoundError: [Errno 2] No such file or directory" When using django

" FileNotFoundError: [Errno 2] No such file or directory" When using django

I get this error: FileNotFoundError: [Errno 2] No such file or directory: '/home/runner/.cache/pip/pool/44/03/28/common-passwords.txt.gz
when trying to run a django application. I have tried reinstalling django, and also clearing pip cache. When I go into “see hidden files” I do not see a .cache file.

Can you send the link to your Repl?


Try moving everything out of Mcclone and rename manage.py to main.py

Doesnt work, I need to have manage.py for the django app to work.

k then instead of renaming manage.py just import manage in main.py

I am running the app from console anyway, main.py does not get run as far as I can tell.

Console or the Shell?

shell not console… that’s only way it work

I’m facing the exact same issue when trying to create a superuser for my Django/Wagtail project. I tried many solutions but nothing seems to work.

Please help? :thinking:

I mean could it be some kind of a bug within Replit that prevents it from rendering Django-based projects correctly or something?

It’s really worth investigating, in my humble opinion.