Favicon Suddenly Disappearing

I was adding some stuff to my site when suddenly the favicon stopped showing up. I didn’t touch the element so I’m not sure what happened.
Repl link:
Code: PS Custom Nikes - Replit
Full Screen: PS Custom Nikes | Home

Quick note you don’t need to add index.html to the end (https://ps-custom-nikes.redcoder.repl.co/ works fine), and it’s happening to me too.

I made a fork and made the favicon thing [link]/images/icon.png and it still doesn’t work.

Ctrl-shift-r try to force-reload?

I did. It looks like a bug with Replit but I can’t be sure

remove the type attribute from your link[rel=icon:

<link rel="icon" href="/images/icon.png">
1 Like

@UMARismyname Just came back to this problem cause it happened again and I realized I never solved it on the first website that it happened.

Still not working :frowning:

My new link is: Estus on Replit

It works fine for me



It also works for me on my tablet but doesn’t work on my PC.

My iPad is running Microsoft Edge and my Windows PC is also running Microsoft Edge.

1 Like

remove this part

<html lang="en-US"></html>

and move the lang attribute to your actual html tag at the top of the code.
You may then need to do f5 on the webpage to refresh the cache


Guess that was the problem :slight_smile:
Thanks for the help!

Still not working for me. I’m in Edge 116.0.1938.69 (Official build) (64-bit) on Win11 Home and I see only the page icon

I’m using Edge and on Windows11 Home and it seems to be working.
Screenshot 2023-09-05 180731

Maybe try


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.