Error with Microsoft.CognitiveServices.Speech

speech_synthesizer = SpeechSynthesizer(speech_config=speech_config)

RuntimeError: Exception with error code:

/home/runner/doitallapp-api-azure/venv/lib/python3.10/site-packages/azure/cognitiveservices/speech/ [0x7f7fd85c3717]

Would be so much easier to use a dockerfile to create the environment…

Hello could you provide the community with a link to your code so we can better help you with your problem thank you

1 Like


I found I need to install libpthreads libssl1.1 libasound, but I don’t find any of there in nix

I made it work, here:

I added to replit.nix:

But when I try to do the same in a more complex app with more requirements, I get this error:

/usr/bin/env: symbol lookup error: /nix/store/4nlgxhb09sdr51nc9hdm8az5b08vzkgx-glibc-2.35-163/lib/ undefined symbol: _dl_fatal_printf, version GLIBC_PRIVATE

Any nix experts around?

1 Like

How can I reset the nix environment without forking the repl?

1 Like

If you mean like rebooting the repl, you could try kill 1, but if you mean resetting the replit.nix file, then you would have to copy an un-edited one from another repl.

1 Like

No, I meant deleting the whole environment and rebuilding from the replix.nix and requirements.txt. The order of package install may have messed it up, or I may have manually installed packages.

Replit doesn’t use a requirements.txt file, they use poetry. Should be two files listed under Packager Files.

requirements.txt is also listed under Packager Files, I guess they added support, or maybe I used pip to install manually.
Anyway I would like to reset the environment, I need to fork??

Not by default, something happened to the repl I suppose.

Possibly, I don’t know.

Can you please clarify what exactly you are trying to reset here?

if you go to the shell and you use nix or pip to install packages, they get installed into the repl, I guess into the venv folder (not sure)
I want to reset that as if I just created the repl

For example I just did:

nix-env -f ‘’ -iA vim ffmpeg.bin wget python310Full replitPackages.prybar-python310 replitPackages.stderred libuuid alsa-lib openssl_1_1 glibc

installing ‘vim-9.0.0609’
installing ‘ffmpeg-4.4.2’
installing ‘wget-1.21.3’
installing ‘python3-3.10.8’
installing ‘prybar-python310-0.0.0-dirty’
installing ‘stderred-0.1.0’
installing ‘util-linux-minimal-2.38.1’
installing ‘alsa-lib-’
installing ‘openssl-1.1.1s’
installing ‘glibc-2.35-163’
building ‘/nix/store/qf5vxpdz7mahky7ybn60p9fivqx23qcm-user-environment.drv’…

But unfortunately I still get the error running the app

/usr/bin/env: symbol lookup error: /nix/store/4nlgxhb09sdr51nc9hdm8az5b08vzkgx-glibc-2.35-163/lib/ undefined symbol: _dl_fatal_printf, version GLIBC_PRIVATE

are there any differences in the .replit/replit.nix config between the app and the repl you provided? Try without the glibc package since a version of is given by dependency of anyhow.

This is a problem with replit not the code, as just cloning the repo without any changes solved the issue