Error when installing the Ursina package

hi I’m currently trying to install use ursina in python i write from ursina import what happens is it will give me an error with a reply with that, ursina is imported but unused, can anyone please help

Hey @dylan2008jan welcome to the forums.

Can you please provide us with a link to the repl?

1 Like

use anything imported from the ursina module to remove that errorwarning.

could you go into more detail because i tried it and i just want to check if im doing it right before i say it wont work

Hi @dylan2008jan thanks for your question. I forked your Repl (thank you for linking to this) and see that the error is:

Warning: unable to auto-locate config files in directory named by "<auto>etc".
package_folder: /home/runner/FirebrickBrokenSearch/venv/lib/python3.8/site-packages/ursina
asset_folder: .
Traceback (most recent call last):
  File "/home/runner/FirebrickBrokenSearch/venv/lib/python3.8/site-packages/ursina/", line 48, in __init__
    import Xlib
ModuleNotFoundError: No module named 'Xlib'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "", line 1, in <module>
    from ursina import *
  File "/home/runner/FirebrickBrokenSearch/venv/lib/python3.8/site-packages/ursina/", line 10, in <module>
    from ursina.window import instance as window
  File "/home/runner/FirebrickBrokenSearch/venv/lib/python3.8/site-packages/ursina/", line 367, in <module>
    instance = Window()
  File "/home/runner/FirebrickBrokenSearch/venv/lib/python3.8/site-packages/ursina/", line 58, in __init__
    from screeninfo import get_monitors
ModuleNotFoundError: No module named 'screeninfo'

I realise you are able to install the package and I created a different Repl which replicates the same error message but with different code (the beginner example on the ursina website).

I think that the problem is you are attempting to use ursina within a browser window.

I also looked at NixOS Search for the package and it wasn’t supported by NixOS.

I can only suggest that you log this as a bug report with Replit Support by clicking on Report a Bug from the ? icon bottom left of any Repl.

I forked it as well and saw that just before this happens, poetry does have an error in installing ursina: KeyError: 'ursina'. It seems it’s failing to find → install the dependencies.

The problem must be a corrupted poetry.lock. I deleted poetry.lock, and now when I poetry add ursina, it’s successfully in the ‘resolving dependencies’ stage. Will edit when it finishes (if at this point :yawning_face:)

This issue is solved here, but there is another issue with a missing library. I can’t find the library on nix