Error: The deployment could not be reached

One of my repls (deployed at cpu.recombinary.com) seems to eventually fall over at least once or twice a day.

It’s a super simple expressJS server and I’ve tried everything I can to find an issue but I’m pretty sure the problem is with the actual deployment itself - When trying to access the
deployed API I get the response { data: 'The deployment could not be reached' }.

This has been happening for about a week now, and is critical infrastructure for my business - so would appreciate some advice here. I have a couple of similar apps deployed and no issues with any of them.

The only thing that seems to fix it is redeploying, and then things work fine for another couple of hours before it falls over again.

Hey @DanDavey!

When I visit your website, I received a different error:

Can you please send me the link to your Repl so I can take a look?

I have the same issue: https://api.requesty.ai/
Repl link: https://replit.com/@lnoot/RYbackend

Hey @ShaneAtReplit

Thanks for replying.

Yeah that’s the expected error i.e. the API is working and needs a bearer token to do anything else. But it’ll start saying “deployment can’t be reached” eventually

Link is https://replit.com/@DanDavey/cpu

1 Like

Similar issue here @ShaneAtReplit

Maybe another useful bit of information (I assume this is the same as for @DanDavey thus keeping it all in this thread):

When I was running the API as an ‘always on’ Repl, it worked perfectly without interruption.

When I connected the ‘always on’ repl to a custom domain, it always showed the ‘this repl is not running’ page.

Then when I deployed it (on that custom domain) it always works for a limited amount of time, until it shows ‘deployment can’t be reached’.

Can you send me a screenshot of the deployment error you are getting? I have checked your website a few times today, but have never come across the deployment error.

1 Like

Hey @lnoot!

It looks like your Repl isn’t working on it’s own:

Please check out our Troubleshooting Guide for Deployments to ensure that your Repl runs properly before deploying and is configured correctly.

Raw link to the guide: https://docs.replit.com/hosting/deployments/troubleshooting

2 Likes

Thanks for your response @ShaneAtReplit

That’s because it requires further information for the api to respond to you. Here’s an example:
https://rybackend.lnoot.repl.co/analytics?organization_id=$org_2Tkhaig11LfEC9bJ43gfPlTsftu

Thanks for the info! When I checked the link you provided, I did not receive a deployment error. If this happens again, can you please send me the time in UTC of when the issue happens so we can crosscheck the issue in our logs?

1 Like

Hi @ShaneAtReplit, sorry I should have been a bit more explicit in my explanation:

The problem is on the custom domain that is attached to the deployment.

This link only works for a limited amount of time after re-deploying:
https://api.requesty.ai/analytics?organization_id=$org_2Tkhaig11LfEC9bJ43gfPlTsftu

Whereas this one always works:
https://rybackend.lnoot.repl.co/analytics?organization_id=$org_2Tkhaig11LfEC9bJ43gfPlTsftu

Thanks for the context! I have still been checking the api.requesty.ai link but still haven’t encountered a deployment error. When you see the error, would you mind sending me a screenshot and providing a timestamp in UTC when the error occurred so we can better understand when this happens?

It hasn’t happened since my last re-deploying strangely enough. Will send you more information when it happens again.

2 Likes