Error: prybar-python310, can't stop comand line

Problem description:

repl process died unexpectedly: exit status 1
nix error: building nix env: exit status 1
Output has been trimmed to the last 20 lines
evaluating file ‘/nix/store/l6smcclpy9f3v562q2ljb9zjdswg3ma1-nixpkgs-22.11-src/lib/modules.nix’
evaluating file ‘/nix/store/l6smcclpy9f3v562q2ljb9zjdswg3ma1-nixpkgs-22.11-src/pkgs/top-level/config.nix’
evaluating file ‘/nix/store/l6smcclpy9f3v562q2ljb9zjdswg3ma1-nixpkgs-22.11-src/lib/options.nix’
evaluating file ‘/nix/store/l6smcclpy9f3v562q2ljb9zjdswg3ma1-nixpkgs-22.11-src/pkgs/stdenv/linux/default.nix’

Steps to reproduce:
i can’t stop the comand line
Google chrome

Actual replit.nix:

{ pkgs }: {
  deps = [  
    pkgs.imagemagick6_light for row in reader:

  env = {
    PYTHON_LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath [
      # Needed for pandas / numpy
      # Needed for pygame
      # Needed for matplotlib
    PYTHONHOME = "${pkgs.python310Full}";
    PYTHONBIN = "${pkgs.python310Full}/bin/python310";
    LANG = "en_US.UTF-8";
    STDERREDBIN = "${pkgs.replitPackages.stderred}/bin/stderred";
    PRYBAR_PYTHON_BIN = "${pkgs.replitPackages.prybar-python310}/bin/prybar-python310";
1 Like

What’s in the last line of the nix error? We may need a link to your repl to investigate

This my replit.nix link

I’m having the same error with this web scraping repl using selenium webdriver. The only things I have done to the repl are:

  • Added firefox esr 91 to Nix via running command: firefox and pressing enter in shell.
  • Attempted to install Selenium via packages - but that fails too with the same error as below.
    Link to repl

This error only seems to occur only after using the Shell to add a command to Nix. I have run this code a few months back on replit with no issues, only tried to run it this morning with no luck.

Error received:

/home/runner/Scraper/venv/bin/python3: line 3: exec: : not found
exit status 127

Any ideas on how to fix this are greatly received - hopefully this error gets fixed soon!!

ah, just remove the for row in reader:

run in shell

sed -i 's/-91-unwrapped//' replit.nix

Unless you’ve modified the replit.nix file manually, I would guess that this happened because the channel used in the command not found helper when you ran firefox in Shell uses an older channel to 22.05 (what your replit.nix is on) and has old package versions.
To prevent this in future for now, when you’re given a “command not found” pop-up try to use the keys to get to a package which doesn’t have any version attached to its name, e.g. just firefox-esr.

And, just saying that using replit to bypass any network restrictions is against ToS and will be removed if targeted at schools, and probably anywhere where replit would lose out from being blocked due to the proxies.