Django web preview giving me a url that is not accessible

Problem description:
I have a Django project that is deployed (this works fine) but where I previously used the ‘Run’ option to get a url to test the project before deployment, I now get a url that doesn’t work. There are no errors in the Django project, when deployed it’s working.

Expected behavior:
When I click the green ‘Run’ button in this django app - I should be seeing the landing page for my web app. Up until last week, this run button was working fine.

Actual behavior:
When I click ‘Run’ I’m seeing the project is running without compilation issues but there is a grey screen in the web preview, even if I click ‘new tab’ I’m not getting a url that works.

Steps to reproduce:
This is a private replit, https://replit.com/@AshrafRahman/autom , I can make it public for replit admin staff. Simply click ‘Run’ and you’ll see that a broken link is presented when ‘new tab’ is clicked

Bug appears at this link:
This is the replit https://replit.com/@AshrafRahman/autom , when I click Run I get the link below that is a grey screen in the web preview and a broken link in a ‘new tab’. The web preview remains stuck on ‘loading’

https://af22a9bf-7a8a-4fdb-8f3f-d8daf6dcf3f9-00-lwy6rw3t72p0.hacker.replit.dev/

Browser:
Latest chrome
OS:
Windows
Device (Android, iOS, NA leave blank):
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Replit Core):
I use to be on a boosted replit, I was moved onto CORE, these problems did not exist until today (I last used it a couple of days ago and it was fine)

1 Like


When I click ‘Run’ I get this web preview, stuck on loading and the broken link as previously posted above. I should be seeing my app.

I tried another Django app that I created a couple of months ago, it has the same problem. When I click ‘Run’ I just get a loading screen and a broken link. I have made this guessing game app public : https://replit.com/@AshrafRahman/guessinggame#django_project/views.py

Hi @AshrafRahman , welcome to the forums!
Can you try opening your website in a New tab and see if that works?
Hope this helps!

Hello Nate, I have just tried my project (at work now) - the problem appears to have been resolved both in the web view and the ‘new tab’ option in chrome.

I am assuming something has changed over the the past several hours. I’ll check again when I get home to see if it was an issue with my computer! Thanks.

1 Like

Well this is very odd @NateDhaliwal . It’s not working again, although I’m at home now - but I can’t see why this would be an issue with location, tried my phone’s internet connection - same problem.

@luisreplit thanks for the update on the other thread relating to the dev server. I tried and it’s still not working for me. This is a public django replit - displays the problem in question, even if I click ‘new tab’ https://replit.com/@AshrafRahman/guessinggame

Could you share a screenshot of the page in a new tab? Perhaps it’s a firewall issue

I don’t have a firewall on this machine.

Could you paste the url here? I’m just trying everything I can think of here.

Thanks, https://9ba56e59-2798-4c0e-bb4a-2692f00aa3a0-00-28auhivi1ru0c.hacker.replit.dev/

That works for me, seems like a network issue:

1 Like

Thanks a lot man. So something is blocking this. This is likely why it was working at work this morning- they do have a firewall.

Perhaps try running the windows diagnostics as chrome suggests?

1 Like

I tried that, gives me no solution. I’ll have to work on this at work for now until I find out what’s going on. I did try connecting with my phone too - no idea what’s going on here. Much appreciate your help!

A temporary solution seems to be using a VPN (using a chrome extension with UK IP). I’m based on the middle east, so it appears there is some issue with these new dev urls. My work place is likely using a vpn of some sort and this is why it works there.