Did replit change hosting? Getting API call error suddenly

Question: Hi guys,
I had a chatbot running fine since Christmas via API call between replit and OpenAI assistant API. My frontend is Voiceflow. Since last week, it stopped working and all I get is the “API call error 500”.
Did replit change something significant? I noticed how the URL changed from “.co” to “.app”. I am so sorry - I’m way out of my depth here. Can anybody point me in the right direction?

Not only have I updated the URL, but redeployed the whole thing and I even created a fresh API. I am at the end of my wits.

Yeah they changed hosting a little bit. Can you tell us more about what URLs you’re requesting to? (repl.co ones don’t work at all, and replit.dev ones only stay on for a bit)

3 Likes

Hi man, I appreciate the answer.
The URL initially was:
https://hey-joe-online-coaching-felsenkind.replit.co

It worked fine for about three weeks. When it didn’t, I retraced every step of the way from OpenAI’s assistant API to Voiceflow. I went back to my replit and checked every step there. That was when I discovered the URL changed to:

https://hey-joe-online-coaching-felsenkind.replit.app

I changed it in Voiceflow accordingly, but it didn’t help. I did everything I could think of. I also redeployed the replit / project. But the API call from Voiceflow to OpenAI won’t work anymore. And I suspect, it must have something to do with the hosting. Does any of that make sense to you?

Try deploying an autoscale app, and refrain from using Uptime services!

1 Like

Production type is Autoscale.
What is an Uptime service?

Previously before the changes you could use pingers to keep your Repl awake for free, but those don’t work anymore.

2 Likes

If you’re on autoscale, then just do the switch with the proper deployment name, rather than only the suffix.

Sorry, I don’t understand, what that means. I already subscribed for “Core”.

  1. Switch

What switch can I make and how?

  1. Deployment name

I just used the URL that is displayed in “Deployments → Production”.

So I am not deliberately using a certain suffix. I just copy/pasted the URL into my frontend.
I’m a total newbie to the whole topic and got into it via YouTube tutorials. That’s as far as I got on my own. Thanks so much for your replies!

I just learned, that the code needs to be deployed “Always on”, but that option doesn’t even show, when I deploy it. I upgraded to Core before I deployed the code - and I did that with Autoscale.
Now, after I deleted the old deployment and made a new one, my chatbot is up and running again. How can I secure, that it will stay up an running?

You’d need a reserved VM for that.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.