Deployments stopped working. Hostingpid1: an open port was not detected

Problem description: When I deploy python repls they fail promotion with the last thing being a Hostingpid1 message.

Expected behavior: I press deploy and python web server starts.

Actual behavior: I press deploy and promotion fails.

Steps to reproduce: I’m not sure if it is reproduceable, but I ha e tried making a blank python repl and creating a flask server with ghostwriter ti test, and that fails in the same way.

Browser:I hqve tried chrome and firefox, but I assume all.
OS:I have tested deployments on windows and android
All devices
All versions
Pro Plan

Hey, @rexhall welcome to the forums!

Can you please provide a link to the repl? This way it is easier for staff and members of the community to help you!

Also see this guide on how to share your code:

1 Like

this is the link I think

Hi @rexhall !

Luckily, this is an error we’ve encountered before. Please feel free to review this forum post if you haven’t already for troubleshooting ideas and assistance:

I’ve looked through this, and I cant seem to resolve my issue.

Part of that forum includes the troubleshooting guide and a calendar link you can use to book a debugging session. Please feel free to get additional help as needed:

hi, i already check the troubleshooting guide and set my app to listen to but still the same i have this error hostingpid1: an open port was not detected i didnt configure any port in one of my file

Try to test to see if the site is up within 5 seconds, this was the issue with one of my repls. If not, see if there is an older version of the code that worked that you can revert to.