Deployments not working

I’m trying to deploy a couple of codes to run an experiment online, both of them run on replit and have no errors. regardless I get this message for both of them when trying to deploy:

error: The deployment failed to initialize due to a configuration or code error. Check the logs tab for more information. For additional support, please post on https://ask.replit.com/c/help/13 and a staff member will take a look.

this is the link to the first: https://replit.com/@ramotslab/corsi-task and the link to the second: https://replit.com/@ramotslab/SVR
would appreciate help!

Hi @mayamechaly. I believe these are local applications so you wouldn’t be able to deploy them at this time. You can certainly redesign them to get ready for deployment. Here’s a few relevant threads explaining more.

1 Like

I was under the impression this is what deployments are for. Since I’m rather new to programming, I don’t really know how to design my code so it would run in a browser.

You don’t necessarily need to deploy it; it depends on what you’re looking to accomplish. You can always share links to your Repl. Or invite others to your Repl via Multiplayer if you’re looking to collaborate.

What you have now is not meant to be deployed to the web (in general, not just at Replit). Pygame, for example, is designed for creating desktop applications, which means the games or projects you develop with it are meant to be run locally on a computer.

Pygame doesn’t have built-in capabilities for creating web-based applications. If you’re looking to create a game or an application that people can access easily over the web, you can explore other technologies that have web deployment capabilities.

1 Like