Deployment test, urls are changing

I forked my Always On replit and called it DTEST, to make a first attempt / experiment with deployment. The Repl is called https://replit.com/@latinlens/DTEST.

Problem description: The project deployed successfully. But SOME of the links are being corrupted / changed.

Expected behavior: The internal links used by the site should not change.

Actual behavior:
Hovering over the ‘About’ link for example, the browser reveals ‘https: //dtest-latinlens.replit.app/about’ as the link. But when I click on this link, the page displays correctly but the url the browser displays is https: //d-8553b4b4-7624-4867-8ae4-c6abc369f71d-3flpixfloq-uc.a.run.app/about/

Steps to reproduce:
Go to https://dtest-latinlens.replit.app and hover on ‘about’, notice the url it reveals; and then click on ‘about’ and notice the url it takes you to.

Plan (Free, Hacker, Pro Plan): Hacker

I’ll decode/summarize this if anyone is confused:

Basically, their deployment domain is https://dtest-latinlens.replit.app, but when they press certain links such as the About link on their website, it’s redirecting to what looks like an a.run.app domain, likely the Deployment version of replID.id.repl.co.

When I went to run.app, it was actually a Google website, which gets me thinking: Are Deployments hosted by Google? And why can you go to that page and get a 404?

Anyway yeah, that’s really weird and odd. I don’t understand how they expect us to switch to Deployments when it’s already so glitchy and problematic.

Now, I wonder, this may be related to the ongoing issue with read-only file systems or whatever, which is shown above as a banner. Honestly, it might be. But, can you tell us when this issue started occurring? Did you report it as soon as you noticed?

The issue started occurring just today. I have never tried a Deployment before, so I ran my first attempt, and this issue appeared immediately. Yes, I reported it here as soon as I noticed it. As of this moment, it is still happening.

Very very odd. Can you try copying the HTML code of that page, deleting the old page, and try to remake the file and paste the contents back? Not sure, just some things to try.

The weird thing is that the page displays correctly, it is only the url that is modified. This is a Python Flask app so I don’t think there is any ‘remake’ process, but please advise if I have misunderstood your question.

Just a note that the problem remains unresolved. I tried forking the replit and deploying the fork, and the problem was still there. I would like to start using deployment, but can’t have my urls being rewritten…

I’ve deleted the previous test replit (DTEST) and forked and deployed another attempt here:

[https://py-ll-latinlens.replit.app/] / https://replit.com/@latinlens/PyLL. It is currently Deployed.

I’ve obtained a little more clarity about this problem. It seems if you enter the Deployment through the main .replit.app address and you do not specify a route such as /about/, the domain displays correctly. You can click on the other relative routes in the header, and the domain remains unchanged.

However - and forgive any lack of technical clarity in my explanation, as I am far from experienced in these matters - if you enter the Deployment website on any route other than the main route, and not from its own internal links on its header, then the domain changes from py-ll-latinlens.replit.app to d-16b197b3-3108-47b8-903b-7f5efdf88f58-3flpixfloq-uc.a.run.app.

This is the case with the .app domain provided by replit, and also with the custom domain that I use.

To reproduce, paste any of the following routes into your browser (make sure you do not have pages cached) and see if ‘py-ll-latinlens.replit.app’ is still the domain displayed when you land on the page:

py-ll-latinlens.replit.app/about
py-ll-latinlens.replit.app/documents
py-ll-latinlens.replit.app/frequency

Did it work for you?

When I load these pages, py-ll-latinlens.replit.app changes to d-16b197b3-3108-47b8-903b-7f5efdf88f58-3flpixfloq-uc.a.run.app.

Could someone from Replit please comment on this? Have I configured my Deployment incorrectly? Or is d-16b197b3-3108-47b8-903b-7f5efdf88f58-3flpixfloq-uc.a.run.app the correct address for this Deployment? For others using Deployments, if you enter your site from a specific route such as /home/ or /about/ does your domain display correctly?

Thought I saw another topic about that. I’ll go scout for it. Can’t find it, but I did see something on it

1 Like

Thanks for looking - - it seems to be resolved for now. I cannot replicate the error any longer. I don’t know what changed.

1 Like

Same for me, I had the issue but it has been resolved for days

1 Like