Deployment of Twitter OAuth2 Fork

Question:

I’ve just forked the following project https://replit.com/@twitter/TypeScript-with-OAuth-20-user-authentication, followed all the steps and tried to do an auto-scale deployment. However, when trying to deploy to an auto-scale instance, i get deployment errors.

easiest way to reproduce the issue is to fork the repl, provide client id and secret id from twitter developer portal (check out readme of repl https://replit.com/@twitter/TypeScript-with-OAuth-20-user-authentication#README.md) and then try to deploy

Repl link/Link to where the bug appears:

Screenshots, links, or other helpful context:
Below is the output i get

2024-03-01T13:22:10Z info: Deployment: c068b915-1c4b-41fb-abe9-e0025944cda4
2024-03-01T13:22:10Z info: Build: f6864c5a-b766-4bc5-b766-3dea6116ccc5
2024-03-01T13:22:10Z info: Connecting to builder
2024-03-01T13:22:10Z info: Deployment: c068b915-1c4b-41fb-abe9-e0025944cda4
2024-03-01T13:22:10Z info: Build: f6864c5a-b766-4bc5-b766-3dea6116ccc5
2024-03-01T13:22:10Z info: Connecting to builder
2024-03-01T13:22:11Z info: Builder connected
2024-03-01T13:22:11Z info: Installing packages
2024-03-01T13:22:11Z info: Starting Build
2024-03-01T13:22:12Z info: Pushing pid1 binary layer...
2024-03-01T13:22:13Z info: Created pid1 binary layer
2024-03-01T13:22:15Z info: Skipping Python layer creation
2024-03-01T13:22:15Z info: Skipping Node layer creation
2024-03-01T13:22:15Z info: Pushing Repl layer...
2024-03-01T13:22:15Z info: Pushing hosting layer...
2024-03-01T13:22:15Z info: Nix layers for this Repl are uncached.
2024-03-01T13:22:15Z info: Pushing nix-0 layer...
2024-03-01T13:22:15Z info: Created hosting layer
2024-03-01T13:22:15Z info: Created Repl layer
2024-03-01T13:22:57Z info: Created nix-0 layer
2024-03-01T13:22:57Z info: uploading image for cached layer
2024-03-01T13:22:58Z info: pushed cache image manifest
2024-03-01T13:22:58Z info: pushed cache soci index manifest
2024-03-01T13:22:58Z info: uploading cached layer
2024-03-01T13:22:58Z info: succesfully uploaded cached layer
2024-03-01T13:22:59Z info: Pushed image manifest
2024-03-01T13:22:59Z info: Pushed soci index manifest
2024-03-01T13:23:40Z info: Creating Autoscale service
2024-03-01T13:25:26Z error: The deployment failed to initialize due to a configuration or code error. Check the logs tab for more information. For additional support, please post on https://ask.replit.com/c/help/13 and a staff member will take a look.

Welcome to Ask @ArturBegyan!

Do you see any errors in the logs tab of your deployments?