Deployment Logs tab: Response not successful: Received status code 500

Problem description:
When I open Logs tab I have a message: Response not successful: Received status code 500

Expected behavior:
Of course the logs should be visible.

Actual behavior:

Steps to reproduce:

Bug appears at this link:

Browser:
OS:
Device (Android, iOS, NA leave blank):
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Replit Core):

Can you provide us with a screenshot of the problem and a link to your repl so that it will be easier for us to help you solve the problem?

Of course:
https://replit.com/@RafalChmielecki/Szatynka2

First I am waiting for the logs to be loaded:

And then I have the 500 message (if even), sometimes it just hangs:

Your link is not working because your repl is private. Can you make the repl public (before doing this, make sure that the repl does not contain API keys and other secret information)?

I can not do it unfortunately. But the problem seems to be with the logs themselves. The workload works properly. I can not see logs, logged as usual. The problem persists after some time after the deployment is done. First couple of minutes I can see logs and then they’re gone. I dont think it’s also the sizing problem, as the log is not even 10 kb.

Does your repl work outside of deployment? Is your program running continuously?

I have the same issue. The deployment works technically fine, but cannot see logs.

image

1 Like

Yes, it works when I just “run” it. And it also works properly after the deployment. I simply have no access to logs. And this issue is on and off. Sometimes logs are visible and sometimes I get status 500. The deployment works: https://szatynka-2-rafalchmielecki.replit.app/

I have exactly the same behaviour. Looks like a platform bug.

This is becoming like a global Replica problem. We need to wait for the help of the administrators so that they can investigate, since I am powerless here.

1 Like

I am having the same issue today.

Hey there! This is an active incident, you can see its status at https://status.replit.com

1 Like

The status is saying “solved” but for me, I stil see nothing (instead of the previous status 500 error).