Deployment issue


Just getting started with Replit and loving all of it so far!

I have a node.js project that I am attempting to deploy. As of yesterday it was working just fine, as of today, it’s stuck on the “Bundle” phase. I haven’t changed the underlying code, and can confirm due to a linked git repo.

My run command is “node server.js” which works as expected in the Replit shell (and loads the site into the web view), also “npm start” works just as well.

I have tried including “npm install” in the build command, but it has no change on the bundling phase error.

Here are the current logs:

info: Deployment: c96b25e7-5acc-4df4-9103-6fd73c40bfe0 - 2023-05-06T16:25:34.293Z
info: Build: b9aa1cfd-8146-486c-971c-875a2eb49b05 - 2023-05-06T16:25:34.293Z
info: Connecting to builder - 2023-05-06T16:25:34.294Z
info: Builder connected - 2023-05-06T16:25:36.350Z
info: Installing packages - 2023-05-06T16:25:36.454Z
info: Skipping Build as no Build command set - 2023-05-06T16:25:37.079Z
info: Pushing pid1 binary layer… - 2023-05-06T16:25:37Z
info: Pushing Repl layer… - 2023-05-06T16:25:46Z
info: Pushing hosting layer… - 2023-05-06T16:25:46Z
info: Retrieved cached nix layer - 2023-05-06T16:25:46Z
fatal: failed to push layers - 2023-05-06T16:25:46Z

Would love any help debugging.

Thank you!

1 Like

@ShaneAtReplit maybe?

I am experiencing the same error as well at the moment. Can’t even start it anymore, stuck on “Resuming” for quite some while now.


I am experiencing the same error right now…everything is fine with the run command, but deploying stops with fatal: failed to push layers.

Bug also appears at and also other repls.
Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Hey, sorry about this – over the weekend we’ve been having intermittent quota issues with our container registry. It should be back up now. Thanks for reporting!

1 Like

Are there still quota issues? I’ve been stuck on info:Created hosting layer during Bundling all day.