Deployment Failing : Flask : Despite installing the package

Question:
My deployments seem to be continuously failing, when when I have installed the package. The package in question is Flask.
The following is the error I get

    from flask import Flask
ModuleNotFoundError: No module named 'flask'
Traceback (most recent call last):
exec [python3 main.py] error=exit status 1

Repl link/Link to where the bug appears:
The issue appears when I try to deploy the app. It works find when I play the same normally. However, it continuously fails to deploy
This is despite me installing the Flask package
Screenshots, links, or other helpful context:

from flask import Flask
app = Flask(__name__)

Hello @AdityaVithaldas, welcome back!

Please edit your post’s code to be formatted like this:

```py
Your code here
```

So that it is easier for staff and members of the community to help you with your issue!

Also see this guide on how to share your code:

PS: if you cannot edit your post, please read around a little to increase your trust level and let you access editing your posts.

cc: @MattDESTROYER @UMARismyname

1 Like

How have you tried to install the package? Using pip, Replit’s built in package manager, or another package manager?

I have installed the package through the “Packages” component. I would imagine that if I use “pip”, that would not carry forward to the deployment.

I have also checked the poetry file, to ensure that Flask is included.

Additionally, I also created this as a Flask project in Replit, but oddly while it worked when I started, it started failing after I added a bunch of code to it.

Try running kill 1 in the shell.

Out of poetry, upm, and pip, pip is the one that causes the most issues when used directly, and it’s recommended not to do so.

2 Likes