Deployment failing at Bundle stage

Question:
My repl is failing to deploy, gets snagged at the bundle stage. Unfortunately the logs don’t tell me much (anything). Not sure if I’m missing something that I can share which may help. Have run through the troubleshooting guide (https://docs.replit.com/hosting/deployments/troubleshooting) and nothing has worked so far.

Project runs within replit workspace, is an autoscale deployment (last deployment a week ago was OK, but have made significant code changes since then)

Repl link/Link to where the bug appears:
https://replit.com/@flixr/Flixr-Creative-Analysis (private)

Screenshots, links, or other helpful context:

2024-02-01T06:00:25Z info: Deployment: ab4ecb32-e314-4b2b-9f14-7085e0bdabe4
2024-02-01T06:00:25Z info: Build: 4827253a-d2ef-4f44-963a-5509d1252d62
2024-02-01T06:00:25Z info: Connecting to builder
2024-02-01T06:00:27Z info: Builder connected
2024-02-01T06:00:28Z info: Installing packages
--> poetry env list --full-path

2024-02-01T06:00:28Z info: Skipping Build as no Build command set
2024-02-01T06:00:28Z info: Pushing pid1 binary layer...
2024-02-01T06:00:30Z info: Created pid1 binary layer
2024-02-01T06:00:33Z info: Skipping Python layer creation
2024-02-01T06:00:33Z info: Skipping Node layer creation
2024-02-01T06:00:33Z info: Pushing Repl layer...
2024-02-01T06:00:33Z info: Pushing hosting layer...
2024-02-01T06:00:34Z info: Retrieved cached nix layer
2024-02-01T06:00:34Z info: Created hosting layer
2024-02-01T06:04:58Z info: Created Repl layer
2024-02-01T06:04:58Z info: Pushing Repl (cache) layer...
2024-02-01T06:05:01Z info: Created Repl (cache) layer
2024-02-01T06:05:01Z error: could not create bundle

@flixr It’s good to hear that it works in the Workspace. If it fails at the bundling step, that usually means it’s a module or Nix issue. Did you add any modules? If so, do any of those modules have dependencies we can update?

If nothing stands out, would you mind inviting me to your Repl so I can take a look?
Username:
SuzyAtReplit

@SuzyAtReplit I tried splitting this out into a separate Repl and it worked. No idea why that would fix it but it deploys now.

@flixr That’s great to hear. Thanks for letting us know.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.