Deployment failed for standard MediaWiki template - no logs

How to deploy standard MediaWiki template using Replit Deployments? There’s no application logs to go off of. Thank you in advance.
Repl link/Link to where the bug appears:
Deployment Page - Promote Section
Screenshots, links, or other helpful context:

code snippet


Unfortunately I’ve also encountered this error while deploying the template.
I’ll try to have a look again but with previous experimenting this doesn’t really seem that possible.

1 Like

Right on sir, thank you again for your help.

I have seen deployment logs when I attempted to redeploy and it’s not passing the promote health check that Replit does. I’m seeing 500 HTTP requests for what I believe are the Replit promote / instance health checks.

I’m also working my way through the Replit troubleshooting checklist:
" 1. Are you relying on SQLite or the file system for data storage? The file system available in deployments is not persistent, and gets reset every time you deploy your Repl. For data persistence, we recommend using a database such as our integrated PostgreSQL."

I’m currently using SQLite and will try to reinstall with Replit’s Postgres.

I’m hoping the Replit team reviews every recommended template like this MediaWiki template to ensure that extremely basic deployments like this case don’t have issues.

I’ll follow up with a Replit troubleshooting session if changing to Postgres doesn’t work.

Thank you for reading.

Follow up:
Swapping to Replit’s Postgres database didn’t fix the failed deployment ( on the promote stage ).

I guess I’ll try to setup troubleshooting time with the Replit team to get it working.

I’m extremely annoyed as a customer, “Always On” deployments “just worked”.

Downgrade to: Very Annoyed.

I re-read the trouble shooting tips and noticed that the port you run on has to be set to port 80.

" 1. Do you have any ports specified in the .replit config? If you have any ports specified, we turn off port auto-detection and rely on the config you have provided. You must specify a port in the config with an externalPort equal to 80 in order for the promotion step to pass. Make sure your server is listening on the specified localPort."

Changing the port to port 80 in my .replit AND using Replit’s Postgres database allowed the Mediawiki Replit template to be deployed.

Closing this post and marking this as the solution for others who might suffer my pain in the future.

This template actually isn’t an official Replit template, it’s one made by a community member (@haroon!) :slight_smile:

1 Like

Hi Ray,

I used the words “every recommended template” specifically because this MediaWiki template is one that Replit shows you when when you click on Replit’s create new template button and a reflection on what Replit is suggesting you use.

I’m well aware of who Haroon is which I thought was evidenced by my reply to Haroon “Right on sir, thank you again for your help.” ( they were helpful in another issue I had regarding MW ) and that this is a community template. My issue is that Replit is suggesting in the Create New Template feature that this is a “production”-ish ready template for Replit Deployments. ( I’m finding that even after having solved the deployment issue that there are perhaps latency issues / caching issues that require researching and fixing before publishing to my customers )

As a customer, I appreciate your comment and reaching out.

The main reason this wasn’t production ready is because at the time of me making this Deployments weren’t out yet (and also I’d never used Deployments until recently).

Although honestly I feel like this is more of a problem with the Deployment system as if developing ( allows any port to be used, the deployed version ( shouldn’t just take away that freedom and not allow you to use any port and force you to use port 80.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.