Deploying kaboom template, without modifying anything, doesn't work

Problem description:

1.- Create a new project form Kaboom template
2a.- Deploy it (using public folder dist - default - )
3a.- index.html looks for game.js in dist folder, but it’s deployed in ./

2b - Deploy it (using public folder ./ )
3b - Build fails with error : fatal: public directory does not contain an index.html file
Expected behavior:

A template should be deployed out of the box and work

Actual behavior:

The index.html and the game.js and other js resources are not well linked

Steps to reproduce:
create a new project using kaboom template and deploy

Bug appears at this link:

OS: Linux
Device (Android, iOS, NA leave blank): Workstation
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Hacker, Pro Plan): Pro

Using a static deployment btw

Hi @mpuntic13 , welcome to the forums!
It appears that this repl is private and we can’t see it from the Cover Page to look at the file structure. Could you make it public and send the link to the Cover Page (not the Deployed url)?


Sure, I switched it to public and the Cover Page is:

Notice that it runs correctly when pressing ‘Run’ and the file structure was unmodified from the template. The problem is when deploying in static mode.

Hi @mpuntic13 !
Try Deploying it as Auyoscale. Since it has some sort of backend, Autoscale should work.
Hope this helps!

1 Like

autoscale requires a build command, you mean I have to build the package myself and keep it in sync with the online editor?

1 Like

Hi @mpuntic13 and thanks for sharing your issue.

I forked the Kaboom template (guessing it is this one as located from Kaboom’s website) and deployed it with all the default settings in a Static deployment. It worked without issue.

The only thing is that “dist” is actually my default public directory. I’m not sure why your default is ./ but that’s probably the differentiating factor.