Default timeout in deployed website

Description of the problem (please keep it simple and short):
Default timeout in deployed website is 5 minutes for a request. My app needs at least 10 minutes currently.

Explain what you were trying to do:
I have deployed my backend website using Autoscale Deployments. I am using Python and Django with Gunicorn. Part of my .replit file is a 900 seconds timeout limit definition because my backend makes several calls to OpenAI API and the process takes up to 10 minutes right now. Unfortunately when I call the endpoint from Postman after 5 minutes I receive request timeout. The Postman is set to infinity and there was no problem when I called it locally. So I would like to know if there is a possibility to change this default setting?

What areas or features are involved?
Deployment.

Repl Cover Page Link/Screenshots/Etc: (to protect you and your code, never share your Repl join link outside of PMs)

Hi @krastenics , welcome to the forums!
You can deploy a website that will be on 99.9% of the time and won’t (really) shut off, instead of turning on when there is an incoming request.
You can use a Reserved VM deployment, but choosing Web server and not Background worker.
Hope this helps!