Default C# code is running indefinitely with no output and no error

Problem description:
Running the default C# code that is provided with a new C# replit result in the code running indefinitely without ever printing “Hello world”, nor throwing any error. It just runs until it is manually stopped.

Expected behavior:

  • “Hello world” being printed to the console.
  • The code stopping automatically at the end of execution.

Actual behavior:

  • Console doesn’t output anything.
  • Code execution doesn’t stop until it is manually stopped.

Steps to reproduce:

  1. Create a new C# replit.
  2. Run the code.
  3. Check for the console and wait.
  4. Stop the execution whenever you had enough.

Bug appears at this link:
Absolutely nothing has been changed from the default code provided with a new C# replit.
Here’s a link anyway

Browser: NA
OS: Android 12
Device (Android, iOS, NA leave blank): Android (Samsung S10E)
Desktop app version (Avatar menu->“Version”) or NA: NA
Plan (Free, Replit Core): Free

Looks okay to me. It did take maybe 10 seconds to run so you might try waiting a bit.

Ok so I tried letting it run for longer.
It took 31 seconds to output “Hello World”. This is not normal.

Ok so I tried it again and I’ve let it run longer. It still took 31 seconds just to output “Hello World”.
A simple code like this shouldn’t take that long to execute. I’m affraid to add anything to the code now haha

Ok so I did try and let it run for longer.
It took 31 seconds just to output “Hello World”. This is not normal :face_with_diagonal_mouth:

Yeah, it does take a bit longer than I anticipated. We’ll look into that part to improve the performance.

1 Like

We’ve made some performance improvements to the C# template. It did hit some CPU bottlenecks for a free user which ultimately made it take longer than a Core user. Now as a free user, if you fork it (and possibly kill it once in the shell), you should be able to get it down to around 9 seconds or less. Core users will get 4-8 seconds more consistently.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.