Debugger does not run on code when I click "Run"

Problem description:
Error when using debugger.

Expected behavior:
I try to debug my code but debugger does not start when I click “Run” (blue triangle icon).

Actual behavior:
When I run the debugger, I get the folowing message:

 could not read stderr: Traceback (most recent call last):
  File "/nix/store/ann2w0blx5vrc8mw1hwnvb37gry6ci9a-replit-python-dap-wrapper-1.0.0/bin/dap-python", line 16, in <module>
    import debugpy
ModuleNotFoundError: No module named 'debugpy'
failed to run adapter: could not parse port from adapter: strconv.Atoi: parsing "": invalid syntax: EOF

Steps to reproduce:
Just launch the following link, choose Debugger and click “Run”

Bug appears at this link:


Try running this in Shell:

poetry add debugpy

and if that fails because it’s already added:

poetry install

Hope this helps!


It solved my problem ! Thanks.
Note: This had been automatically upgraded just before the problem happened.
I don’t know if this is related.
I’ve been using the debugger for a while and it was working fine.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.