Day 85 of 100 Days of Code

Problem description:
I have copied and pasted David’s code directly from the tutorial in the left sidebar, but the Repl won’t run in webview at all or even in a new tab. It just produces a blank white screen. Opening in a new tab causes it to go into “waking repl…” mode that keeps loading the progress bar (so it’s not frozen), but the progress bar goes back down to 0 when it reaches the end and keeps starting over. The tab shows a loading icon next to the tab title.

Expected behavior:
I expect the webview tab to load a form as it loads in the tutorial video. I expect the same behavior opening it in it’s own tab.

Actual behavior:
When I click Run in editing mode, it changes to the Stop button for about 5 seconds and then changes back to the Run button. The webview pane says “Repl waking up” and keeps loading the progress bar over and over again as I mentioned above under Problem Description. I already restarted my computer and it’s still happening. I tried closing and opening the project in new tabs before restarting.

Steps to reproduce:
I don’t know if it’s reproducible, but I’m trying it now logged out in Incognito browser and it’s not running the Repl there either.

Bug appears at this link:
https://replit.com/@libraryguyeli/85100-HTTP-and-Sessions#main.py

Browser/OS/Device:
MacBook OS Ventura 13.1

Hi @libraryguyeli thank you for your post. You’ve included lots of detail!

I was able to fork your Repl and when I clicked on run I got the following error:

image

There was no delay in loading and running the Repl.

I assume this needs a key which you’ve already added to your own Repl, so I won’t be able to go any further.

Are you able to try accessing the same Repl from a different network e.g. a 4G hotspot? It might be that the network you are using to access Replit is somehow blocking a key element of the site.

1 Like

It’s possible my workplace wifi is blocking the session feature. I just tried again, and I was able to get the webview pane to load the form, but I ran into the same problem again when I added the next set of code that involved the session feature.

I’ll try it at home on my own wifi and report back. Thanks for your help.

1 Like

So I tried on my home wifi and it still didn’t work, so I shut my MacBook down. Came in to work today and the repl was working! Briefly. I was able to finish the tutorial, but then when I copied over all the code from the previous day for the challenge, it started doing the same thing it was doing originally. I even commented out almost all the code excluding the index page, just to see if it would work. And it’s not working still.

Here’s the link again in case anyone wants to test it: https://replit.com/@libraryguyeli/85100-HTTP-and-Sessions#main.py

I’m really not sure what’s going on with this thing. I may have to try a different device or something, but that’s not sustainable for me to complete the 100 Days of Code if this continues to happen.

1 Like