Cycle purchase bugs with strip vs gpay

Problem description:
Purchasing cycles with a credit card doesn’t work on gpay for a specific card, but the same card worked fine using gpay

Expected behavior:
Typing the credit card in using Stripe would work – as all credentials were the same.
A reasonable reason for decline other than “couldn’t validate” via stripe would have been helpful.

Actual behavior:
The payment went through on first attempt

Steps to reproduce:
Enter the USD card (from a Canadian Bank institution, but in USD).
Type in all the same valid credentions in stripe form.
It works! Instead of requiring re-doing in gpay option from a Mac.

Bug appears at this link:

Mac M1 Pro 2021. Chrome, recently updated.
Hotel Wifi.
Travelling in the USA with a Canadian Institution Card demonated in USD.

@bardia What does the P1 mean in the assignment test? Priority one? We should probably have a topic explaining this.


Just had the issue again. Strip through Link when logged in results in error/can’t be authenticated.
Log-out, use GPAY with the same card and credentials… and it works. For logs, happened in the past ~3 minutes. It is 6:59am eastern time on December 12th. Using Desktop, Mac M1, Chrome Browser.

1 Like

Hey there, we’re looking into this, but in the meantime, if you attempt another purchase, please double check your billing details, try deleting and reentering the card, or use another card if possible.

1 Like

I did. Didn’t work with stripe. Worked with gpay all the same details. Identical. It’s a corporate card.

Thanks for the update, I’ll relay this to the eng team.